Scroll to top

System Requirements

EmailMeForm is fully web-based platform that is hosted on our site. So there's nothing to download or install. EmailMeForm can be used with Windows, Mac or Linux computer as long as you're using a supported web browser and have an Internet connection.

The supported browsers are:

  • Google Chrome - Recommended Latest

  • Internet Explorer 10.x and higher, 9.x^, 8.x^

  • Firefox -Recommended Latest

  • Safari - 9.x, 8.x, 7.x^, 6.x^, 5.x^

You must also have JavaScript and cookies enabled in your browser.

While our product will work with older browsers as noted, please note limited support will be provided to older browsers noted with "^". We highly recommend keeping your browser updated to the latest version for the best possible experience.

The forms we create strive to be compatible with as many devices as possible, however each device may render differently.

 

Updated: Dec. 2015

Have more questions? Submit a request.

0 Comments

Article is closed for comments.